Categories
DuxTel Systems (11)
Interface Cards and Adapters (14)
Mikrotik Systems-> (159)
Mimosa Wireless (5)
RouterBOARD (11)
Router Enclosures (11)
Power Supplies & PoE-> (29)
Antennas and Accessories-> (106)
Mikrotik RouterOS (6)
Assembled Kits (6)
Carrier Wireless (1)
Cable and Misc (14)
Hardware and Mounting (23)
Configuration Library (FREE!) (7)
Quick Find
  
search products
search articles
Articles
New Articles
Case Studies
Product Guides (2)
Mikrotik Configuration (17)
Technical (5)
Community News (9)
Q&A (28)
Product Advisory (7)
Policy and Information (7)
Information
Shipping & Returns
Privacy Notice
Conditions of Use
Contact Us
Sierra Wireless Modem Integration Guide by Adnan Zafar

Sierra Modem integration Guide

Establish 3G PPP session

Step 1: Verify that the correct APN is in use. Common APNs in Australia include:

Operator

APN
Telstra (Private, dynamic IP) telstra.internet
Telstra (Public, dynamic IP) telstra.extranet
Telstra (Private, static IP, authentication) telstra.corp
Optus internet, internode*
Vodafone vfinternet.au
M2M (Private, dynamic) telstra.m2m
M2M (Public, dynamic) telstra.extranet
M2M (Private, static)  

 

* editors note: since publishing this article, we have received advice that optus APNs also include yesinternet for contract services and preconnect for prepaid internet SIMs

 

 Step 2: Verify data and info channels are correct for the module in use. Typical assignments are as follows:

Card Data Channel Info Channel
MC8780 2 2
MC8790/V 4 3
MC8795V 4 3
MC8700 3 2
MC8704 3 2
MC8705 4 3
MC8801 3 2
MC7701V 4 3
MC7304 2 0

To verify the info and data channels, the following procedure is useful:

Disable the PPP interface, start a ‘New Terminal’ from winbox. Type in:

/system serial-terminal port=usb2 channel=3

When the terminal opens up, issue:

AT+CGDCONT?

 If this is the info channel, the module should reply with
something along the lines of: 

AT+CGDCONT=1,”IP",”telstra.internet”

On the data channel, your key presses are not echoed and issuing a AT+CGDCONT results in an error. The data channel will respond ‘OK’ when ‘AT’ is issued.

Step 3: Sometimes, despite having the correct APN, the module doesn’t take the setting through winbox.

This can be verified by issuing a AT+CGDCONT to the info channel of the module through the router boards
serial terminal. The APN can be forced by issuing:

AT+CGDCONT=1,”IP",”telstra.internet”

Step 4: Some SIM cards are PIN locked.

Winbox provides a field to enter this PIN, but as above, sometimes
this does not work. To manually force the PIN setting on the Routerboard, the following command should be
issued on the info channel of the module:

AT+CPIN=”1234”

To verify, issue AT+CPIN? The response should be “Ready”

Step 5: Verify signal strength.

Without adequate signal, the PPP connection can range from flaky to completely inoperable. The info button located on the PPP tab will provide this information. The minimum allowable signal strength for a stable connection is in the -90dBm region.

Common Problems

A: Interface/s not appearing

Step 1: Ensure USB settings are correct.

Look in System -> Routerboard -> USB for the dropdown box. Set this to "mini-PCI-e" if it is not already.

/system routerboard usb set type=mini-PCIe

Step 2: If your module is LTE another change is required.

Look in System -> Ports -> Firmware for the 'Ignore DirectIP Modem' checkbox. This will need to be checked for your interface to apear.

/port firmware set ignore-directip-modem=yes

Step 3: Power off the system.

The system will need to be completely powered off for these changes to apply.

B: 3G connection up, however, no internet access

Step 1: Verify masquerade NAT rule.

Look in IP -> Firewall -> NAT for the masquerade rule. The default setup is:
Chain: srcnat
Out. Interface: ppp-out1
Action: masquerade

Step 2: Verify DHCP settings.

Ensure that the correct DNS servers are being handed out via DHCP. Verify gateway address matches that of the Routerboard.

C: Routerboard resets frequently

Step 1: Ensure the watchdog settings are correct.

Make sure the IP address specified is always up and preferably as local as possible to the Routerboard. An easy to remember, reliable, low latency address is 8.8.8.8 (Google’s public DNS)

Step 2: To debug hardware related faults involving sudden resets, open a terminal to the devices serial port.

Fatal crash information will be printed to the terminal. After a crash has occurred the ‘supout’ file can be generated and sent to Mikrotik support. This file can be generated from this guide: http://wiki.mikrotik.com/wiki/Manual:Support_Output_File

D: Flash corrupted, unable to boot into RouterOS

This often occurs if power is interrupted during the upgrade process. This leaves the Routerboard in a nonbootable
state. ‘Netinstall’ can be used to PXE boot the router and reinstall firmware:
http://wiki.mikrotik.com/wiki/Netinstall

E: Port forwarding issues

Step 1: Check system service settings

If you are using a port that is associated to a Routerboard process, you must disable that service or
use a different port. E.g. a port 80 port forward requires the www service to be disabled or moved to a
different port from IP->Services

Step 2: Ensure you are using a SIM card with a public IP.

Telstra SIMs require the telstra.extranet APN to be
enabled. Optus SIMs, by default receive public addresses.

Step 3: Check destination address.

Ensure the port forward is pointing to a machine with a static IP address or a static DHCP leased
address. If the machine’s IP changes, the port forward will not work.

Step 4: Verify that the port forward rule is being matched and forwarding packets.

Go to IP->Firewall, for each rule listed, there is a ‘Packets’ column showing how many packets have matched the rule. This is useful for verifying inbound communication.

Step 5: Check destination host.

Ensure the machine which is to receive the port forward has the gateway specified or some sort of default route to the Routerboard IP.

Download the original pdf version of this document

Date Added:
Current Comments: 0
Write Review
Tell a friend
Tell a friend about this article:  
Shopping Cart
more
0 items
Latest News
about 1 day ago
Cute as a button! The hAP-mini 3 port wifi router from MikroTik has finally passed all relevant certifications! Ge…
more >>
about 10 days ago
LOOK! The new wsAP-lite is a dual band WiFi AP with passthrough PoE ethernet that fits into a power point profile!
more >>
about 10 days ago
The new LtAP-mini is the ideal mobile and vehicle connectivity system with GPS - add your own 4G modem for the ulti…
more >>
about 10 days ago
The cool new RBLHGG-60adkit Wireless Wire Dish Kit is on its way - available for pre-order right now!
more >>
about 11 days ago
DuxTel News: Half-price Mimosa, MikroTik LTE updates, MUM 2018 Highlights -
more >>
about 01 month ago
CCR1072-1G-8S+ - it doesn't get any better than this! Normally $4325, special price $2999 - (ex demo model, 1 unit…
more >>
about 01 month ago
ready for MikroTik Certified Training - kicking off TOMORROW! :)
more >>
about 01 month ago
MikroTik's first ever true 802.3af/at PoE switch with auto-detecting 24v/48v and 4x 10GB SFP+ uplink is available n…
more >>
about 01 month ago
Thinking about horns? See here! :)
more >>
Follow our tweets for all the latest news and updates!
twitter.com/duxtel
Reviews
more
RBCA450G: RB450G kit with indoor case - assembled
The RB450G is the swiss army knife of routers. The amount of ..
5 of 5 Stars!

Copyright © 2018 DuxTel Online Store